~singpolyma/network-protocol-xmpp

Bump version to 0.4.4.
cf9f4296 — John Millikin 9 years ago
Add 'sessionIsSecure' function, so users can check whether the current
session is running over a secure channel.
0b6293df — John Millikin 9 years ago
Require haskell-gnutls >= 0.1.4, because earlier versions crash when
credentials are used as they are in XMPP/Client/Handle.hs .
ebee48a2 — John Millikin 9 years ago
Remove maximum dependency versions for bytestring and network.
Bump version to 0.4.3.
626e7adf — John Millikin 9 years ago
Support authentication schemes that require post-success validation.

Fixes authentication failures with the SCRAM-SHA1 mechanism, reported
by Gergely Risko.
404dae3c — John Millikin 9 years ago
Fix build of example/echo.hs.
Minor cleanups. Remove maximum version of "transformers" dependency.
Clean up Cabal file.

Bump package version to 0.4.1.
8ef50c31 — John Millikin 10 years ago
Fix build in GHC 7.4.1.
Reduce use of the ($) operator.
7e5c7a26 — John Millikin 10 years ago
Replace SaxEvent with plain Event
e87755ea — John Millikin 10 years ago
Use strict text and bytestrings for everything.
731d27fa — John Millikin 10 years ago
Use the IsString instance of Name.
7cd1a925 — John Millikin 10 years ago
Misc stylistic cleanups
de832b9d — John Millikin 10 years ago
Quick-n-dirty port to updated xml-types and libxml-sax.
Version 0.3.3
36054a11 — John Millikin 10 years ago
Update homepage and repository URLs.
fac747ad — John Millikin 10 years ago
Require gnuidn-0.2
In the "echo" example, 1) don't respond to error messages and 2) allow
subscriptions.
Next